Scheduled for 26 March, 2026 at 9:00 PM – 28 March, 2026 at 1:00 AM
Affects
EnderDevelopment - Official Site
Under maintenance from 9:00 PM to 1:00 AM
Dashboard
Under maintenance from 9:00 PM to 1:00 AM
EndAI - Core
Under maintenance from 9:00 PM to 1:00 AM
Updates
Completed
28 March, 2026 at 1:00 AM
Completed
28 March, 2026 at 1:00 AM
Maintenance has completed successfully
Update
27 March, 2026 at 5:50 PM
Update
27 March, 2026 at 5:50 PM
After ~20 hours of ongoing maintenance, we’ve achieved a major breakthrough in build performance.
We’ve successfully optimized the system to the point where ~80% of Minecraft plugins now build successfully on the first attempt, compared to ~10% previously.
We identified this issue later than expected, and we sincerely apologize for the impact it may have caused.
To make up for it, we will be sending an email to all users with a special discount.
Work is still ongoing as we continue refining the system — but this is a huge step forward.
Thank you for sticking with us
In progress
26 March, 2026 at 9:00 PM
In progress
26 March, 2026 at 9:00 PM
Maintenance is now in progress
Planned
26 March, 2026 at 9:00 PM
Planned
26 March, 2026 at 9:00 PM
We are initiating a long-term maintenance window (~28 hours) to implement major improvements to our core architecture and plugin generation system.
This work is focused on addressing the current high rate of build and code failures, with the goal of delivering a more reliable, stable, and high-quality output pipeline.
The platform will remain fully online, however you may experience:
Temporary fatal errors
Intermittent availability
Slower processing or failed tasks during restarts
This is a significant upgrade aimed at fundamentally improving system performance and consistency.